From PyMOLWiki
Jump to navigation Jump to search

I've added some details about where and how to download and install apbs and its dependencies. I have cross-referenced a description of how this can be done on OS X.

I've put a few very tentative lines in about linux.

Well done!

Hey, thanks for this plugin. It worked on an SMP 64-bit Linux machine with little effort. Still crashes a bit, but the effort is worth it. Tree 18:21, 21 February 2008 (CST)


I ran APBS on 2ILK. When I try to show the solv. acc. map, it computes something for a sec, then crashes taking PyMOL with it. Is this common? Any ideas on fixing it? It's probably my lack of understanding on how APBS works. Tree 07:40, 22 February 2008 (CST)

For me it doesn't crash, but asks me to calculate the pqr file myself. Than it calculates the map fine. Desastre 27 April 2008

Making the default paths to work?

I saw a discussion in the Pymolbb dated April 15, 2010 [1] about the default paths for binaries,, and temp files not loading automatically or even saving the paths.

I am wondering if anyone has solved this issue.

After installing pymol through fink, none of the binaries show up. After installing pdb2pqr through fink, the apbs plugin (Apbs Tools 2) does load /sw/share/pdb2pqr/ automatically. However, after installing apbs-mpi-openmpi through fink, neither APBS binary nor APBS load.

I have tried modifying (/sw/lib/pymol-py26/modules/pmg_tk/startup/ in lines 112 through 115 to: APBS_BINARY_LOCATION = '/sw/bin/apbs-mpi-openmpi' APBS_PSIZE_LOCATION = '/sw/share/apbs-mpi-openmpi/tools/manip/' APBS_PDB2PQR_LOCATION = None TEMPORARY_FILE_DIR = None

My $APBS_PSIZE returns /sw/share/apbs-mpi-openmpi/tools/manip by default, as installed through fink. I use 64-bit fink, pymol 1.3, and Snow Leopard OSX.

The default temporary file locations also do not work. I have also tried to make apbs plugin save these these to no avail.

I hope a solution to this issue can be posted in the wiki.

PS.: I have looked at the output from X11 when pymol loads, and it seems it tries to load trying /sw/bin/apbs-mpi-openmpi/ trying /sw/share/apbs-mpi-openmpi/tools/manip/ trying /sw/share/pdb2pqr/

and trying /sw/bin/apbs-mpi-openmpi/apbs.exe trying /sw/share/apbs-mpi-openmpi/tools/manip/ trying /sw/share/pdb2pqr/apbs.exe trying /sw/share/apbs/tools/manip/apbs.exe trying /sw/bin/apbs.exe

Which are obviously wrong. The correct paths should be /sw/share/apbs-mpi-openmpi/tools/manip/ and /sw/bin/apbs-mpi-openmpi. --Rendereason 22:40, 20 July 2010 (UTC)

Fixed in the current version of the plugin, which you can download from my user page. The issue was that the plugin just didn't know about MPI-enabled versions. --michael 23:48, 22 July 2010 (UTC)

Running with APBS 1.3 not working

Well, I tried making the plugin run with APBS 1.3 and this is what I got:

 args=('/usr/local/apbs-1.3-mac-univ/bin/apbs', '--version')
 Results were:
 Return value: -5
 dyld: Library not loaded: /usr/local/lib/x86_64/libgomp.1.dylib
   Referenced from: /usr/local/apbs-1.3-mac-univ/bin/apbs
   Reason: image not found
 Skipping /usr/local/apbs-1.3-mac-univ/bin/apbs because it appears to be broken (dyld)

Just wondering if you get the same. --Rendereason 16:36, 29 October 2010 (UTC)

I think I see why it's doing that. My folder structure is not right. APBS needs to update its install instructions/README. I'll try moving the folders to /sw64/bin/apbs, /sw64/share/apbs, etc.--Rendereason 16:49, 29 October 2010 (UTC)

The installation guide says: "The APBS binaries do not contain dependencies on special data files, etc. and can be moved out of this directory structure without causing any problems for APBS execution." From APBS webpage. I have tried setting the variable ${APBS_PREFIX} to /usr/local/apbs-.13-mac-univ. I've added these to my .zshrc but none of it works


None of this had any effect on the unmodified (When parameters set to None) Changing the parameters within to their desired folders gives the error above. --Rendereason 16:57, 29 October 2010 (UTC)

Have you tried the pre-release version available on my page? I fixed some things recently, and this bug doesn't happen for me any more. --michael 19:40, 29 October 2010 (UTC)

Yes. Those errors happen with the pre-release version you posted. It also ignores the binary I have configured it to use in /usr/local/apbs/bin/ for the fink one in /sw64/bin/.

Also, I get this problem when running the plugin:
 Erasing contents of /tmp/pymol-generated.pdb in order to generate new PDB file
 Erasing contents of /tmp/pymol-generated.pdb in order to clean it up
 Appended /sw64
 Unexpected error encountered while trying to import pdb2pqr: (<type 'exceptions.ImportError'>, ImportError('No module named pdb2pqr.pdb2pqr',), <traceback object at 0x116714908>)
 In show error 2
 Could not generate PDB2PQR file.  _generatePdb2pqrPqrFile failed.
 Could not generate PQR file!

--Rendereason 22:48, 4 November 2010 (UTC)

OK, I think I know what's causing at least some of the problems. I find email a lot easier than wiki pages for sorting all of this out. Can you send a list of the current errors you're getting along with your PyMOL version, APBS version, PDB2PQR version and operating system to me at my gmail account (mglerner)? Thanks! --michael 00:43, 5 November 2010 (UTC)