Difference between revisions of "Pse export version"

From PyMOLWiki
Jump to: navigation, search
(created)
 
(scenes in 1.8.4)
 
Line 21: Line 21:
 
The following objects are not or only partly supported:
 
The following objects are not or only partly supported:
  
* scenes before 1.7.6
+
* scenes before 1.7.6 (support added in 1.8.4)
 
* volumes before 1.7.2
 
* volumes before 1.7.2
 
* ramps
 
* ramps

Latest revision as of 13:03, 5 October 2016

The pse_export_version setting switches to a legacy format when saving PSEs, so far possible. The value is the floating point number representation of the targeted legacy PyMOL version, for example 1.74 to save a session for PyMOL 1.7.4.

New in PyMOL 1.7.6

Session file loading is always backwards compatible, so any newer version of PyMOL can load old session files.

Examples

# current version (default)
set pse_export_version, 0
save current.pse

# compatible with PyMOL 1.7.4
set pse_export_version, 1.74
save 174compat.pse

Known Limitations

The following objects are not or only partly supported:

  • scenes before 1.7.6 (support added in 1.8.4)
  • volumes before 1.7.2
  • ramps
  • CGOs

See Also